Search

Language:  
Search for:

Available article translations:

[Info] OS version compatibility for container migration or upgrade

Article ID: 3591, created on Feb 4, 2008, last review on Nov 21, 2014

APPLIES TO:
  • Plesk 12.0 for Windows
  • Virtuozzo containers for Windows

Information

This article illustrates OS compatibility during container migration or upgrade of the Hardware Node OS:

Windows 2012 Family

Windows 2012 is supported since Parallels Containers for Windows 6.0.

Windows 2012 R2 is not yet supported.

Target
SourceW2K12W2K12 R2
W2K12YESN/A
W2K12 R2N/AN/A

*Migration is allowed between hosts with the same language only.

Windows 2008 and Windows 2008 R2 Family

Windows 2008 is supported since Parallels Virtuozzo Containers for Windows 4.5.

Windows 2008 R2 is supported since Parallels Virtuozzo Containers for Windows 4.6.

Target
SourceW2K8 SP1W2K8 SP2W2K8 R2W2K8 R2 SP1
W2K8 SP1YESNONONO
W2K8 SP2NOYESNONO
W2K8 R2NONOYESNO
W2K8 R2 SP1NONONOYES

*Not all Windows 2008R2 SP1 editions and locales are supported by Parallels Virtuozzo Containers for Windows. For more information, refer to this article:

113610 Windows 2008R2 SP1 locales and editions supported by Parallels Virtuozzo Containers for Windows

In addition to the tables above, keep in mind the following migration requirements:

  • Architectures must be the same. Migration from x86 to x64 and vice versa is not supported.
  • No migration is possible between Windows Server 2003 and Windows Server 2008.
  • Host OS localization versions must be the same.
  • Hosts must be the same product type, i.e., migration between Enterprise and Datacenter editions is not supported. (The only exception is migration between Windows 2003 Standard and Enterprise editions, which is supported.)
  • For Windows 2008 and Windows 2008 R2, the source host and destination host must either both have Hyper-V enabled or neither have it enabled. If one of the hosts has Hyper-V enabled and the other does not, the migration will result in an error.

NOTE: Migration via PMC is called with force flag; thus, the compatibility check for the source and destination nodes is omitted.

NOTE: UPGRADING FROM WINDOWS 2008 TO WINDOWS 2008 R2 IS NOT SUPPORTED:

  • It is not possible to upgrade Windows 2008 to Windows 2008 SP1 or SP2.
  • It is not possible to upgrade Windows 2008 SP1 to Windows 2008 SP2.
  • It is not possible to upgrade Windows 2008 to Windows 2008 R2.
  • It is not possible to upgrade Windows 2008 R2 to Windows 2008 R2 SP1.

Windows 2003 Family

Target
SourceW2K3 SP1W2K3 SP2W2K3 R2 SP1W2K3 R2 SP2
W2K3 SP1YESYESYESYES
W2K3 SP2NOYESNOYES
W2K3 R2 SP1NONOYESYES
W2K3 R2 SP2NONONOYES

Search words:

Containers

Upgrade

plesk

migration

Compatibility

Windows

Migration

sd




2897d76d56d2010f4e3a28f864d69223 965b49118115a610e93635d21c5694a8 d02f9caf3e11b191a38179103495106f a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c ed7be2b984f9c27de1d2dc349dc19c6d 85a92ca67f2200d36506862eaa6ed6b8 a766cea0c28e23e978fa78ef81918ab8

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No
 
 
 
 
 
 
Server Virtualization
- Odin Cloud Server
- Odin Containers for Windows 6.0
- Odin Virtuozzo Containers
Automation
- Odin Automation
- Odin Automation for Cloud Infrastructure
- Odin Business Automation Standard
- Odin Virtual Automation
- Odin Plesk Panel Suite
- Web Presence Builder
- Odin Plesk Automation
- Odin Small Business Panel
- Value-added Services for Hosters
- Odin Partner Storefront
Services & Resources
- Cloud Acceleration Services
- Professional Services
- Support Services
- Training & Certification